1. Home
  2. Quick Guides
  3. Streaming Settings
  4. How do I fix video sync / lag issues in ManyCam?
  1. Home
  2. Getting Started
  3. Live Stream with ManyCam
  4. How do I fix video sync / lag issues in ManyCam?
  1. Home
  2. ManyCam Features
  3. Settings
  4. How do I fix video sync / lag issues in ManyCam?
  1. Home
  2. Troubleshooting
  3. How do I fix video sync / lag issues in ManyCam?

How do I fix video sync / lag issues in ManyCam?

Requirements

Before you proceed, install this version of ManyCam to make sure you are running the latest version.

If you experience a lag between audio and video in ManyCam, please try the solutions below:

Adjust audio delay

Run ManyCam, navigate to ManyCam’s Audio tab, find the Audio Input toolbox and try adjusting Sync Offset to set a custom delay for your microphone. You might need to experiment with this setting to find the correct value. Make sure that your microphone is selected as an Audio Input device, otherwise, Sync Offset will not be available.

Step 1: Access the Sync Offset setting:

Step 2: Adjust the delay

Adjust video delay

Alternatively, you can set a delay for your video feed. To do so, right-click on the Main Live Window and select Resolution (macOS) or Properties (Windows) as shown below.

Windows:

macOS:

macOS

Video Sync Offset is located at the bottom of the window. We recommend keeping the rest of the settings set to Auto.

The default step size of the video delay correction is also 10 ms. Similarly, holding down the Ctrl key while adjusting the delay will increase the step size to 100 ms.

Adjust integrated webcam settings (Windows only)

Right-click on the Main Live Window and select Properties to open your webcam’s settings as shown below. Make sure your webcam is selected as a video source.
In the opened window, find any settings related to RightLight, AutoFocus, Face Tracking or similar and disable them (features might be named differently depending on what webcam you use). Don’t forget to save the changes.

Adjust the Hardware Acceleration settings

Open ManyCam Settings -> General and try selecting other Hardware Acceleration options (including disabling it). Also, try and set Hardware Acceleration buffer size to Single Buffer or disable it completely.

Enable Force Driver output resolution (macOS only)

Change the default video device (macOS only)

Try selecting the options available to you under Use Video Device.

Switch to Ethernet cable

In order to improve the bandwidth, please disable your Wi-Fi connection on your machine and connect to the Internet through an Ethernet cable directly.

Sometimes lag occurs as a result of increased CPU utilization. Please see this guide to troubleshoot this.

Updated on October 9, 2020

Was this article helpful?

Related Articles

Not the solution you were looking for?
Click the link below to submit a support ticket
Contact Us